Major US Comcast Outage (Not Phaxio service affecting)
Incident Report for Phaxio
Resolved
This incident has been resolved.
Posted 15 days ago. Jun 30, 2018 - 10:26 CDT
Monitoring
Comcast is reporting outages for their customers across the US. This does not affect the Phaxio infrastructure but may affect call completion to Comcast phone numbers or users' ability to reach the Phaxio site.

Comcast updates may be found here: https://twitter.com/comcastbusiness/status/1012753697087115265
Posted 16 days ago. Jun 29, 2018 - 12:59 CDT