Delayed faxes
Incident Report for Phaxio
Resolved
All backlogged faxes have been handled and all systems continue to operate normally.
Posted 4 months ago. May 14, 2018 - 06:54 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. May 14, 2018 - 06:49 CDT
Identified
We are aware of an issue which caused faxes to be significantly delayed.
Posted 4 months ago. May 14, 2018 - 06:26 CDT
This incident affected: API and Web Console.