Delayed Faxes
Incident Report for Phaxio
Resolved
Faxes are processing properly.
Posted over 1 year ago. Feb 22, 2017 - 07:26 CST
Monitoring
Faxes are processing without delay at this time.
Posted over 1 year ago. Feb 22, 2017 - 07:06 CST
Investigating
We're investigating delayed faxes.
Posted over 1 year ago. Feb 22, 2017 - 06:31 CST