Delayed faxes
Incident Report for Phaxio
Resolved
This has been resolved and all faxes are now flowing without any delay.
Posted Apr 07, 2020 - 15:34 CDT
Identified
We are seeing delayed faxing for certain customers on the Phaxio platform. We have identified the issue and are implementing a fix.
Posted Apr 07, 2020 - 15:25 CDT
This incident affected: API.