Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 09, 2022 - 12:00 CST
Scheduled
Phaxio will perform a non-service impacting update on Wednesday, 11/9/2022 between 12:00 pm and 4:00 pm CT. The purpose of the change is to optimize the configuration with our service providers. No degradation of the service is expected during this time. Please reach out to support@phaxio.com with questions or concerns.
Posted Nov 08, 2022 - 15:30 CST
This scheduled maintenance affected: Inbound faxing.