Phaxio Outbound Faxing Event Notification // Parent Case #13473688
Incident Report for Phaxio
Resolved
We have worked with the vendor and the issue is now corrected.

Should you have any questions or experience any service issues, please continue to reach us at support@phaxio.com
Posted Sep 26, 2023 - 15:28 CDT
Identified
We have identified an issue with fax completion issues to Germany (+49800) and Italy (+39800) Toll Free numbers. We are working on correcting the issue and will update as soon as we have one.

If you have any questions please contact our support team at support@phaxio.com
Posted Sep 26, 2023 - 15:19 CDT
This incident affected: Phaxio (Outbound Faxing).