Monitoring notifications email domain update // 10/23/24
Incident Report for Phaxio
Resolved
Hi!

We have updated our proactive monitoring email notifications domain. The new domain will be "notifications.sinch.com".

You may see on some mail providers "support=phaxio.com@notifications.sinch.com" on behalf of "support@phaxio.com" .

If you believe you are missing notifications, please validate you have added this email address to your safe senders list or check your junk/spam folder.

Please do not reply to this email as it is unmonitored. Please reach out to support@phaxio.com with questions or concerns.
Posted Oct 23, 2024 - 14:41 CDT
This incident affected: Phaxio (Email Alerts).